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Getting started with STM32™ Nucleo board software 
 development tools  

Introduction

The STM32™ Nucleo board is a low-cost and easy-to-use development platform used to 
quickly evaluate and start a development with an STM32 microcontroller in LQFP64 
package. 

This document describes the software environment and development recommendations 
required to build an application around the STM32 Nucleo board. It provides guidelines to 
beginners on how to build and run a sample application and allows them to create and build 
their own application. It has the following structure: 

• The first chapter presents software and hardware requirements (some toolchains 
supporting the STM32™ families, ST-LINK/V2-1 installation and firmware package 
presentation). 

• The second chapter provides step by step guideline on how to execute and debug an 
application example using some toolchains: – IAR Embedded Workbench® for ARM® 
(EWARM) by IAR systems® – Microcontroller Development Kit for ARM® (MDK-ARM) by 
Keil® – TrueSTUDIO® by Atollic®. 

This manual doesn’t cover all the topics relevant to software development environments, but 
it demonstrates the first basic steps necessary to get started with the compilers/debuggers 
and offers links to the documents needed to fully understand every single step. 

All boards belonging to the STM32 MCU Nucleo line are supported. 

Figure 1. Nucleo development tools
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1 System requirements

Before running your application, you should:

1. Install your preferred Integrated Development Environment (IDE).

2. ST-LINK/V2-1 driver will be installed automatically. In case of problem, you can 
proceed with manual installation of the driver from toolchains install directory (further 
details are available in Section 3).

3. Download the STM32 Nucleo firmware from www.st.com/stm32nucleo.

4. Establish the connection with the STM32 Nucleo board by connecting CN1 of the 
Nucleo board to the USB port of the PC.

The above steps will be details in the coming sections.

Figure 2. Hardware environment

To run and develop any firmware application on an STM32 Nucleo board, the minimum 
requirements are as follows:

• Windows PC (XP, 7, 8)

• 'USB type A to Mini-B' cable, used to power the board (through USB connector CN1) 
from host PC and connect to the embedded ST-LINK/V2-1 for debugging and 
programming.
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2 IDEs supporting STM32 Families

STMicroelectronics STM32 families of 32-bit ARM® Cortex®-M core-based microcontrollers 
are supported by a complete range of software tools. It encompasses traditional integrated 
development environment IDEs with C/C++ compilers and debuggers from major third-
parties (free versions up to 64KB of code, depending on partner), completed with innovative 
tools from STMicroelectronics.

Toolchains supporting all Nucleo boards are:

• EWARM v7.10.3 or later(a)

– 30-day evaluation edition

– 32 KB Limited QuickStart edition(16KB Limitation for Cortex M0)

• MDK-ARM v5.01 or later (a)(b)

– MDK-Lite (32KB Code size limitation)

• TrueSTUDIO v5 or later(b) 

– 32 KB Limitation (8KB for Cortex-M0)

Information on the toolchain version supporting your STM32 device is available on 
toolchain’s release note at partner web site (See Section 4.2).

Before installing and using the product, please accept the Evaluation Product License 
Agreement available at ww.st.com/epla. 

a. Registration before download is required.

b. The device support pack is separate from MDK-ARM releases.
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3 ST-LINK/V2-1 installation

STM32 Nucleo board includes an ST-LINK/V2-1 embedded debug tool interface. The 
interface needs an ST-LINK/V2-1 dedicated USB driver to be installed. This driver is 
available at ST web site at www.st.com ST-LINK/V2-1 and supported within software 
toolchains:

• IAR Embedded Workbench® for ARM® (EWARM) 

The toolchain is installed by default in the C:\Program Files\IAR Systems\Embedded 
Workbench x.x directory on the PC's local hard disk.

After installing EWARM, install the ST-LINK/V2-1 driver by running the ST-
Link_V2_USB.exe from [IAR_INSTALL_DIRECTORY]\Embedded Workbench 
x.x\arm\drivers\ST-Link \ST-Link_V2_USBdriver.exe

• Keil Microcontroller Development Kit (MDK-ARM) toolchain 

The toolchain is installed by default in the C:\Keil directory on the PC's local hard disk; 
the installer creates a start menu µVision4 shortcut.

When connecting the ST-LINK/V2-1 tool, the PC detects new hardware and requires to 
install the ST-LINK_V2_USB driver. The “Found New Hardware wizard” appears and 
guides you through the steps needed to install the driver from the recommended 
location.

• Atollic® TrueSTUDIO® STM32 

The toolchain is installed by default in the C:\Program Files\Atollic directory on the PC's 
local hard disk.

The ST-Link_V2_USB.exe file is automatically installed when installing the software 
toolchain.

Complementary information on the firmware package content and the STM32 Nucleo 
requirements is available on the Getting started with STM32 Firmware.

Note: The embedded ST-LINK/V2-1 only supports SWD interface for STM32 devices. 
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4 Firmware package

The STM32 Nucleo firmware applications, demonstration and IP examples are provided in 
one single package and supplied in one single zip file. The extraction of the zip file 
generates one folder, STM32 Nucleo_FW_VX.Y.Z, which contains the following subfolders 
(see Figure 3).

Figure 3. Package contents

• Template project is a pre-configured project with empty main function to be 
customized by the user. This is helpful to start creating your own application based on 
the peripherals drivers.

• Example project includes toolchain projects for each peripheral example ready to be 
run. 

4.1 Executing and debugging firmware using software 
toolchains

4.1.1 EWARM toolchain

The following procedure explains how to compile/link and execute an existing EWARM 
project.

The steps below can be applied to an already existing example, demonstration or template 
project available from STM32_Nucleo_FW_VX.Y.Z firmware at www.st.com web site.

First of all, you need to go through the firmware/readme.txt file which contains the firmware 
description and hardware/software requirements.
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1. Open IAR Embedded Workbench® for ARM® (EWARM). Figure 4 shows the basic 
names of the windows referred to in this document:

Figure 4. IAR Embedded Workbench IDE

2. In the File menu, select Open and click Workspace to display the Open Workspace 
dialog box. Browse to select either an example or demonstration or template 
workspace file and click Open to launch it in the Project window.

3. In the Project menu, select Rebuild All to compile your project.

4. If your project is successfully compiled, Figure 5 is displayed.
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Figure 5. EWARM project successfully compiled

If you need to change the project settings (Include and preprocessor defines), go 
through the following project options: 

– For Include directories:

Project>Options…>C/C++ compiler> 

– For pre-processor defines:

Project>Options…C/C++ compiler>pre-processor>      

5. In IAR Embedded Workbench IDE, from the Project menu, select Download and 
Debug or, alternatively, click the Download and Debug button in the toolbar, to 
program the Flash memory and start debugging.

Figure 6. Download and Debug button

6. The debugger in IAR Embedded Workbench® can be used to debug source code at C 
and assembly levels, set breakpoints, monitor individual variables and watch events 
during the code execution.
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Figure 7. IAR Embedded Workbench debugger screen

To run your application from the Debug menu, select Go. Alternatively, click the Go 
button in the toolbar to run your application.

Figure 8. Go button
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4.1.2 MDK-ARM toolchain

1. Open Keil MDK-ARM Microcontroller Development Kit. Figure 9 shows the basic 
names of the "Keil µvision5" windows referred to in this document. 

Figure 9. µvision5 IDE

2. In the Project menu, select Open Project... Browse to select either an example or 
demonstration or template project file and click Open to launch it in the Project window. 

3. In the Project menu, select Rebuild All target files to compile your project. 

4. If your project is successfully compiled, the following window is displayed:
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Figure 10. MDK-ARM project successfully compiled

If you need to change your project settings (Include and preprocessor defines), go 
through the project options: 

– For Include directories:

Project>Options for Target > C/C++ > Include Paths

– For pre-processor defines:

Project>Options for Target > C/C++ > Preprocessor symbols > Define

5. In MDK-ARM IDE, from the Debug menu, select Start/Stop Debug Session or, 
alternatively, click the Start/Stop Debug Session button in the toolbar, to program the 
Flash memory and start debugging.

Figure 11. Start/Stop Debug Session button

6. The debugger in the MDK-ARM can be used to debug source code at C and assembly 
levels, set breakpoints, monitor individual variables and watch events during the code 
execution.
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Figure 12. MDK-ARM debugger screen

To run your application from the Debug menu, select Run. Alternatively, click the Run 
button in the toolbar to run your application.

Figure 13. Run button
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4.1.3 TrueSTUDIO toolchain

1. Open Atollic TrueSTUDIO® for ARM® product. The program launches and requires the 
Workspace location.

Figure 14. TrueSTUDIO workspace launcher dialog box

2. Browse to select a TrueSTUDIO workspace of either an example or demonstration or 
template workspace file and click OK to load it.

3. To load an existing project in the selected workspace, select Import from the File menu 
to display the Import dialog box.

4. In the Import window, open General, select Existing Projects into Workspace and 
click Next.
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Figure 15. Atollic TrueSTUDIO® import source select dialog box

5. Click Select root directory and browse to the TrueSTUDIO workspace folder. 
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Figure 16. Atollic TrueSTUDIO® import projects dialog box

6. In the Projects panel, select the project and click Finish.

7. In the Project Explorer, select the project, open the Project menu, and click Build 
Project.

8. If your project is successfully compiled, the following messages will be displayed on the 
Console window.

Figure 17. TrueSTUDIO® project successfully compiled
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If you need to change the project settings (Include directories and preprocessor 
defines), go through Project>Properties and select C/C++ Build>Settings from the left 
panel: 

– For Include directories:

C Compiler>Directories>Include path

– For pre-processor defines:

C Compiler>Symbols> Defined symbols

9. To debug and run the application, select the project In the Project Explorer and press 
F11 to start a debug session.

Figure 18. TrueSTUDIO debug window

The debugger in the Atollic TrueSTUDIO can be used to debug source code at C and 
assembly levels, set breakpoints, monitor individual variables and watch events during 
the code execution.

To run your application, from the Run menu, select Resume, or alternatively click the 
Resume button in the toolbar.
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4.2 Software toolchain helpful references and web sites

Table 1 gives useful references about the integrated development environments described 
in this document.

          

Table 1. References and web sites

Toolchain Web sites

EWARM www.iar.com

MDK-ARM www.keil.com

TrueSTUDIO www.atollic.com
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5 Revision history

          

Table 2. Document revision history 

Date Revision Changes

19-May-2014 1 Initial release

20-Jun-2014 2
Added new part numbers in the cover page.

Removed Table1 Nucleo board General information.

09-Sep-2014 3
Replaced all rpns of NUCLEO with reference to the “STM32 MCU 
Nucleo” line.
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IMPORTANT NOTICE – PLEASE READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and 
improvements to ST products and/or to this document at any time without notice. Purchasers should obtain the latest relevant information on 
ST products before placing orders. ST products are sold pursuant to ST’s terms and conditions of sale in place at the time of order 
acknowledgement.

Purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or 
the design of Purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.

Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

ST and the ST logo are trademarks of ST. All other product or service names are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2014 STMicroelectronics – All rights reserved
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